summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSøren Sandmann <sandmann@redhat.com>2007-06-13 00:15:34 -0400
committerSøren Sandmann Pedersen <sandmann@annarchy.freedesktop.org>2007-06-21 22:21:11 -0700
commit12cc32b674d3f1b705ef1a66bbce1ef8c4488daf (patch)
treec4d12d745d4c35ed0565885032666fc876d83ad6 /configure.in
parent9109946a1a7f9341e60da7358da6535c5fac52db (diff)
[pixman] Initial port to standalone pixman library.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index bef5d55b..a521cc48 100644
--- a/configure.in
+++ b/configure.in
@@ -102,6 +102,7 @@ if test "x$PKG_CONFIG" = x; then
AC_MSG_ERROR([pkg-config >= $PKGCONFIG_REQUIRED required but not found (http://pkgconfig.freedesktop.org/)])
fi
+
dnl ===========================================================================
dnl
dnl cairo_cache_version should be increased every time that the backend
@@ -232,8 +233,15 @@ CAIRO_NONPKGCONFIG_LIBS="$LIBM"
CAIRO_LDADD=""
CAIRO_CFLAGS=$CAIRO_NONPKGCONFIG_CFLAGS
CAIRO_LIBS=$CAIRO_NONPKGCONFIG_LIBS
-PIXMAN_CFLAGS=""
-PIXMAN_LDADD=""
+
+dnl ===========================================================================
+
+PKG_CHECK_MODULES(PIXMAN, pixman >= 0.9.2)
+
+CAIRO_NONPKGCONFIG_CFLAGS="PIXMAN_CFLAGS $CAIRO_NONPKGCONFIG_CFLAGS"
+CAIRO_NONPKGCONFIG_LIBS="PIXMAN_LIBS $CAIRO_NONPKGCONFIG_LIBS"
+CAIRO_CFLAGS="$PIXMAN_CFLAGS $CAIRO_CFLAGS"
+CAIRO_LIBS="$PIXMAN_LIBS $CAIRO_LIBS"
dnl ===========================================================================
@@ -919,8 +927,6 @@ _EOF
AC_CONFIG_FILES([
Makefile
boilerplate/Makefile
-pixman/Makefile
-pixman/src/Makefile
src/Makefile
test/Makefile
test/pdiff/Makefile