summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2007-08-29 12:18:16 -0400
committerBehdad Esfahbod <behdad@behdad.org>2007-08-29 12:19:05 -0400
commit114b07881e8b09f97394dd4fe8f2900ee9f4c348 (patch)
tree50168f0f18d01e1b50d96f8e0a103158d130f26f /configure.in
parent7f726e57546dba4cdd96086515a372d18c1ee2a9 (diff)
[configure.in] Make PS backend require zlib too (#12210)
The PS backend uses zlib these days. Make it depend on zlib being available like PDF has been doing.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b8c56bd0..212cace4 100644
--- a/configure.in
+++ b/configure.in
@@ -535,7 +535,12 @@ fi
dnl ===========================================================================
-CAIRO_BACKEND_ENABLE(ps, PostScript, ps, PS_SURFACE, auto, [use_ps=yes])
+CAIRO_BACKEND_ENABLE(ps, PostScript, ps, PS_SURFACE, auto, [
+ # The ps backend requires zlib.
+ use_ps=$have_libz
+ ps_NONPKGCONFIG_LIBS=-lz
+])
+
test_ps=no
if test "x$use_ps" = "xyes"; then
AC_CHECK_PROG(GS, gs, gs)