summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-08-06 09:52:34 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2009-08-06 10:11:42 +0100
commita3f393cf644d75065fe524e2fbb28f55844f43bf (patch)
treee89e3a49578e527363ad2265d868c2b25bb68435 /configure.ac
parent51bd27afa147f78c8f4f3778cee725b6444e7eb0 (diff)
[configure] Also check for libiberty.h
cairo-trace also uses the libiberty.h without checking for its presence -- causing a build failure if bfd was installed but not that header.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 083b0ccf..445cb674 100644
--- a/configure.ac
+++ b/configure.ac
@@ -618,6 +618,7 @@ AM_CONDITIONAL(BUILD_TRACE,
AC_CHECK_LIB(bfd, bfd_openr,
[AC_CHECK_HEADER(bfd.h, [have_bfd=yes],
[have_bfd=no])], [have_bfd=no])
+AC_CHECK_HEADER(libiberty.h,, [have_bfd=no])
if test "x$have_bfd" = "xyes"; then
AC_DEFINE([HAVE_BFD], [1], [Define to 1 if you have the binutils development files installed])
BFD_LIBS=-lbfd