summaryrefslogtreecommitdiff
path: root/boilerplate/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-08-06 09:41:15 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2009-08-06 10:11:32 +0100
commit51bd27afa147f78c8f4f3778cee725b6444e7eb0 (patch)
tree8adad0c6c053ce285ab29ec191f329535438e23c /boilerplate/Makefile.am
parent5dd29d7e2da8684ea46c8f1baba42e6dc64f1351 (diff)
[boilerplate/test] Convert make-*-constructors to shell
Remove the intermediate C program that was a nuisance whilst cross-compiling and replace it with a simple shell script that is just a combination of cat + sed.
Diffstat (limited to 'boilerplate/Makefile.am')
-rw-r--r--boilerplate/Makefile.am17
1 files changed, 4 insertions, 13 deletions
diff --git a/boilerplate/Makefile.am b/boilerplate/Makefile.am
index c8b5d41b..cb92c2bc 100644
--- a/boilerplate/Makefile.am
+++ b/boilerplate/Makefile.am
@@ -48,21 +48,12 @@ endif
libcairoboilerplate_la_LIBADD += $(CAIROBOILERPLATE_LIBS)
-# we need to workaround the introduction of CC_FOR_BUILD with older builds
-make-cairo-boilerplate-constructors$(EXEEXT): make-cairo-boilerplate-constructors.c
- if test -n "$(CC_FOR_BUILD)"; then \
- $(CC_FOR_BUILD) $^ -o $@; \
- else \
- $(CC) $^ -o $@; \
- fi
-
-cairo-boilerplate-constructors.c: Makefile $(enabled_cairo_boilerplate_sources) make-cairo-boilerplate-constructors$(EXEEXT)
- echo '(cd $(srcdir) && $(top_builddir)/boilerplate/make-cairo-boilerplate-constructors$(EXEEXT) $(enabled_cairo_boilerplate_sources)) > $@'
- ./make-cairo-boilerplate-constructors$(EXEEXT) $(srcdir) $(enabled_cairo_boilerplate_sources) > $@
+cairo-boilerplate-constructors.c: Makefile $(enabled_cairo_boilerplate_sources) make-cairo-boilerplate-constructors.sh
+ (cd $(srcdir) && sh ./make-cairo-boilerplate-constructors.sh $(enabled_cairo_boilerplate_sources)) > $@
BUILT_SOURCES += cairo-boilerplate-constructors.c
-EXTRA_DIST += $(BUILT_SOURCES) make-cairo-boilerplate-constructors.c
-CLEANFILES += $(BUILT_SOURCES) make-cairo-boilerplate-constructors
+EXTRA_DIST += $(BUILT_SOURCES) make-cairo-boilerplate-constructors.sh
+CLEANFILES += $(BUILT_SOURCES)
test: check