summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 40a97f1..37a6dc0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,13 +11,6 @@ AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE([enable])
-LIB_VERSION=0:0:0
-AC_SUBST([LIB_VERSION])
-
-# Initialize libtool
-AC_PROG_LIBTOOL
-
-
# Checks for programs.
AC_PROG_CXX
AC_PROG_RANLIB
@@ -55,6 +48,9 @@ AS_IF([test "x$with_evemu" == xyes],
AM_CONDITIONAL([HAVE_EVEMU], [test "x$have_evemu" = "xyes"])
AS_IF([test "x$have_evemu" = xyes], [AC_DEFINE([HAVE_EVEMU])])
+AC_SUBST(SOURCEDIR, ['${prefix}/src/xorg-gtest'])
+AC_SUBST(DUMMY_CONF_PATH, ['${datarootdir}/xorg/gtest/dummy.conf'])
+
# Check if we can build integration tests
AS_IF([test "x$enable_integration_tests" != xno],
[AC_MSG_CHECKING([for X.org server])]