summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2008-03-26 19:28:09 -0400
committerKristian Høgsberg <krh@redhat.com>2008-03-31 16:50:58 -0400
commitc40e0b51f0d9ef5e1f30f233d7db1e6db9d6681b (patch)
tree42c40d8123a53c2f04ef0df3144f112395ad75cb /configure.ac
parent8074676d2df8d577b443e3fa5e22d7c71c944bd1 (diff)
Implement DRI2 direct rendering and update AIGLX to DRI interface changes.
Get rid of glcontextmodes.[ch] from build, rename __GlcontextModes to __GLXcontext. Drop all #includes of glcontextmodes.h and glcore.h. Drop the DRI context modes extension. Add protocol code to DRI2 module and load DRI2 extension by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 959f0aedf..e72e3b99a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -860,7 +860,7 @@ AM_CONDITIONAL(DRI2, test "x$DRI2" = xyes)
if test "x$DRI2" = xyes; then
# FIXME: Bump the versions once we have releases of these.
AC_DEFINE(DRI2, 1, [Build DRI2 extension])
- PKG_CHECK_MODULES([DRIPROTO], [xf86driproto >= 2.0.3])
+ PKG_CHECK_MODULES([DRI2PROTO], [dri2proto >= 1.0.0])
PKG_CHECK_MODULES([LIBDRM], [libdrm >= 2.3.1])
fi