summaryrefslogtreecommitdiff
path: root/config/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2010-04-01 23:44:24 -0700
committerKeith Packard <keithp@keithp.com>2010-04-01 23:59:36 -0700
commit24952b786625fef808cb26d539dd5109d623c053 (patch)
tree9536f7c2f7498641422e32c258c8198f6c616c9c /config/Makefile.am
parent02328f190f893cb4ad0f3af7a2ecd39ed77ae5ad (diff)
Install 10-evdev.conf in $(prefix)/etc/X11/xorg.conf.d under udev
udev needs some xorg.conf file to tell it to load a suitable input driver, 10-evdev.conf is as simple as they come, mapping all evdev devices to the evdev driver. Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index 27f251b3a..eed745483 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -9,6 +9,9 @@ AM_CFLAGS += $(UDEV_CFLAGS)
libconfig_la_SOURCES += udev.c
libconfig_la_LIBADD = $(UDEV_LIBS)
+xorgconfddir = $(prefix)/etc/X11/$(XF86CONFIGDIR)
+xorgconfd_DATA = 10-evdev.conf
+
else
if CONFIG_NEED_DBUS
@@ -33,4 +36,4 @@ endif # CONFIG_NEED_DBUS
endif # !CONFIG_UDEV
-EXTRA_DIST = xorg-server.conf x11-input.fdi
+EXTRA_DIST = xorg-server.conf x11-input.fdi 10-evdev.conf