summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Johnson <ajohnson@redneon.com>2010-12-14 09:06:57 +1030
committerCarlos Garcia Campos <carlosgc@gnome.org>2010-12-14 11:51:32 +0100
commit06da4b46c442778c67b788b747f04b386b5247ac (patch)
tree3641f9153dbcf2383fbd271ccbb3c0b52b2ed602 /CMakeLists.txt
parent6ef457dc818e7e241e5d2e264bc2d78b132ae638 (diff)
cairo: Use A1 instead of A8 for imagemask
The cairo PDF surface now optimizes the case of cairo_mask() with solid source and A1 mask to use a PDF stencil mask. Fixes https://bugs.launchpad.net/ubuntu/+source/libcairo/+bug/680628 where a 65K PDF printed to PDF using poppler-cairo turns into an 8MB PDF.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 758c8c91..40437229 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,8 @@ find_package(PkgConfig)
include(MacroEnsureVersion)
include(MacroBoolTo01)
find_package(Threads)
+include(TestBigEndian)
+test_big_endian(WORDS_BIGENDIAN)
set(POPPLER_MAJOR_VERSION "0")
set(POPPLER_MINOR_VERSION "15")