summaryrefslogtreecommitdiff
path: root/gs/base/configure.ac
diff options
context:
space:
mode:
authorChris Liddell <chris.liddell@artifex.com>2011-07-26 13:15:44 +0100
committerChris Liddell <chris.liddell@artifex.com>2011-07-26 13:15:44 +0100
commit1094db4129bb70f9f7a0222683bc7f299cf4629a (patch)
tree3455bb8019d35cabd02577a3f17477aa3d6325ed /gs/base/configure.ac
parenteaec68d05c8d223cb97d89b6a3a9a96e550feeb2 (diff)
Bug 691956: make installing the cups tools optional
Introduces a --with-cups-install option to configure. To include the cups tools and associated data files in Ghostscript's "install" target you will have to specify "--with-cups-install" at configure time. No cluster differences.
Diffstat (limited to 'gs/base/configure.ac')
-rw-r--r--gs/base/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/gs/base/configure.ac b/gs/base/configure.ac
index 885dc4318..1e10144e0 100644
--- a/gs/base/configure.ac
+++ b/gs/base/configure.ac
@@ -752,6 +752,10 @@ AC_ARG_WITH([local-cups], AC_HELP_STRING([--with-local-cups],
[Force using the GS supplied cups code - only useful for debugging]),
[with_local_cups=yes], [with_local_cups=no])
+AC_ARG_WITH([install-cups], AC_HELP_STRING([--with-install-cups],
+ [Install the cups conversion tools]),
+ [CUPSINSTALL=install-cups], [CUPSINSTALL=])
+
CUPSDEV=""
CUPSINCLUDE=""
CUPSCFLAGS=""
@@ -816,6 +820,7 @@ AC_SUBST(CUPSINCLUDE)
AC_SUBST(CUPSSERVERBIN)
AC_SUBST(CUPSSERVERROOT)
AC_SUBST(CUPSDATA)
+AC_SUBST(CUPSINSTALL)
AC_SUBST(SHARELCUPS)
AC_SUBST(SHARELCUPSI)