summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2009-06-04 18:41:35 +0200
committerBenjamin Otte <otte@gnome.org>2009-06-11 10:05:40 +0200
commit5bca61ba06c374b5d4ef197e4805074880ddee20 (patch)
treee4469dcf08bbb7fbb4ab2d6960277db8bd0ebce4 /daemon/Makefile.am
parent5e3ce10bd814834731ac70e584a90b64ab2860fe (diff)
[FTP] rework cache handling
The cache handling has been split into a separate file and structure now. While the API still isn't perfect, it's much clearer than before. It's also faster when looking up lots of symlinks.
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index c9e17ae7..9761eff6 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -231,6 +231,7 @@ gvfsd_obexftp_LDADD = $(OBEXFTP_LIBS) $(XML_LIBS) $(HAL_LIBS) $(libraries)
gvfsd_ftp_SOURCES = \
gvfsftpconnection.c gvfsftpconnection.h \
+ gvfsftpdircache.c gvfsftpdircache.h \
gvfsftpfile.c gvfsftpfile.h \
gvfsftptask.c gvfsftptask.h \
gvfsbackendftp.c gvfsbackendftp.h \