summaryrefslogtreecommitdiff
path: root/stickynotes/pixmaps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'stickynotes/pixmaps/Makefile.am')
-rw-r--r--stickynotes/pixmaps/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/stickynotes/pixmaps/Makefile.am b/stickynotes/pixmaps/Makefile.am
index 56450d6af..57f01464c 100644
--- a/stickynotes/pixmaps/Makefile.am
+++ b/stickynotes/pixmaps/Makefile.am
@@ -32,6 +32,8 @@ uninstall-local:
rm -f $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
done
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
install-data-local:
for icon in $(icons); do \
SIZE=`echo $$icon | cut -d. -f2`; \
@@ -45,3 +47,10 @@ install-data-local:
mkdir -p $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/; \
$(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
done
+ @-if test -z "(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi