summaryrefslogtreecommitdiff
path: root/stickynotes/pixmaps/Makefile.am
diff options
context:
space:
mode:
authorDavyd Madeley <davyd@madeley.id.au>2006-09-04 15:32:24 +0000
committerDavyd Madeley <davyd@src.gnome.org>2006-09-04 15:32:24 +0000
commit26f60e50217890454023106b7308a0fd2b9589ef (patch)
tree0a3a6fe873ec49963e9768d7721b8d36a38a69e9 /stickynotes/pixmaps/Makefile.am
parent51ab8a3a48a0c06a4e78ecad0a79784c387b8150 (diff)
- release GNOME Applets 2.16.0GNOME_APPLETS_2_16_0
2006-09-04 Davyd Madeley <davyd@madeley.id.au> * configure.in: * NEWS: - release GNOME Applets 2.16.0 * geyes/Makefile.am: * modemlights/Makefile.am: * stickynotes/pixmaps/Makefile.am: * cpufreq/pixmaps/Makefile.am: - ensure the icon cache is regenerated
Diffstat (limited to 'stickynotes/pixmaps/Makefile.am')
-rw-r--r--stickynotes/pixmaps/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/stickynotes/pixmaps/Makefile.am b/stickynotes/pixmaps/Makefile.am
index 56450d6af..57f01464c 100644
--- a/stickynotes/pixmaps/Makefile.am
+++ b/stickynotes/pixmaps/Makefile.am
@@ -32,6 +32,8 @@ uninstall-local:
rm -f $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
done
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
install-data-local:
for icon in $(icons); do \
SIZE=`echo $$icon | cut -d. -f2`; \
@@ -45,3 +47,10 @@ install-data-local:
mkdir -p $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/; \
$(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(iconsdir)/hicolor/$$SIZE/apps/$$FILE; \
done
+ @-if test -z "(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi