summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGlynn Foster <glynn.foster@sun.com>2001-09-20 13:52:53 +0000
committerGlynn Foster <gman@src.gnome.org>2001-09-20 13:52:53 +0000
commitae53f058471e9e6eb7ebb07177057117bb550d13 (patch)
treed68b7d500710539e0cf578a082219e36a0571c12 /Makefile.am
parent1dabe415926320290e63c3bd8ccaeb31fb58dc0c (diff)
More slightly sensible changes. We just need libapplet as a pkg-config and
2001-09-20 Glynn Foster <glynn.foster@sun.com> * configure.in, Makefile.am: More slightly sensible changes. We just need libapplet as a pkg-config and then we can begin the next stage.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 10 insertions, 33 deletions
diff --git a/Makefile.am b/Makefile.am
index 12fd5184e..a46f95ef3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,32 +12,12 @@ if HAVE_WORDEXP
wordexp_SUBDIRS = $(wordexp_applets)
endif
-xml_applets = \
- gnotes
-if HAVE_LIBXML
-xml_SUBDIRS = $(xml_applets)
-endif
-
ghttp_applets = \
- gweather
-if HAVE_LIBGHTTP
-ghttp_SUBDIRS = $(ghttp_applets)
-endif
-
-ghttp_vfs_applets = \
gtik
-if HAVE_LIBGHTTP
-if HAVE_GNOME_VFS
-ghttp_vfs_SUBDIRS = $(ghttp_vfs_applets)
-endif
-endif
-
-ghttp_xml_applets = \
+ gweather
slashapp
-if HAVE_LIBXML
if HAVE_LIBGHTTP
-ghttp_xml_SUBDIRS = $(ghttp_xml_applets)
-endif
+ghttp_SUBDIRS = $(ghttp_applets)
endif
esd_applets = \
@@ -73,30 +53,28 @@ always_built_SUBDIRS = \
drivemount \
fifteen \
geyes \
+ gnotes \
gkb-new \
jbc \
life \
mini-commander \
+ odometer \
quicklaunch \
tickastat \
webcontrol \
- whereami \
- odometer
+ whereami
SUBDIRS = \
- intl po macros \
+ intl po \
$(always_built_SUBDIRS) \
$(gtop_SUBDIRS) \
$(ghttp_SUBDIRS) \
- $(ghttp_vfs_SUBDIRS) \
- $(ghttp_xml_SUBDIRS) \
$(cdplayer_SUBDIRS) \
$(mixer_SUBDIRS) \
$(modemlights_SUBDIRS) \
$(esd_SUBDIRS) \
$(wordexp_SUBDIRS) \
- $(xml_SUBDIRS) \
omf-install
DIST_SUBDIRS = \
@@ -105,19 +83,18 @@ DIST_SUBDIRS = \
clipboard \
$(gtop_applets) \
$(ghttp_applets) \
- $(ghttp_xml_applets) \
$(cdplayer_applets) \
$(mixer_applets) \
$(modemlights_applets) \
$(esd_applets) \
$(wordexp_applets) \
- $(xml_applets) \
omf-install
+## I guess we don't need this now?
## to automatically rebuild aclocal.m4 if any of the macros in `macros/' change
-@MAINT@include macros/macros.dep
-@MAINT@macros/macros.dep: macros/Makefile.am
-@MAINT@ cd macros && $(MAKE) macros.dep
+##@MAINT@include macros/macros.dep
+##@MAINT@macros/macros.dep: macros/Makefile.am
+##@MAINT@ cd macros && $(MAKE) macros.dep
EXTRA_DIST = \
COPYING-DOCS \