summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorVladimir Vukicevic <vladimir@pobox.com>2005-12-12 11:56:40 +0000
committerVladimir Vukicevic <vladimir@pobox.com>2005-12-12 11:56:40 +0000
commitc2c4f0bb251423737d46fcde7ffe8711547abf09 (patch)
tree47c6a2a6c9e6fa0751edea43a90f271af3a566e5 /test/Makefile.am
parent840f93698d5a89634c573f25911e9dc6020a46e1 (diff)
bump glitz req to 0.5.1, test for backends
Add glitz backend (original patches from sunmoon1997@gmail.com), including glx, wgl, and agl support. Add CAIRO_TEST_TARGET environment variable for limiting backends to test. Takes all *.log files and spits out html to stdout that can be used to view all test results at once.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 4b2eae720..cb942a8bd 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -254,6 +254,20 @@ xmalloc.h
LDADDS = libcairotest.la $(top_builddir)/src/libcairo.la
+if CAIRO_CAN_TEST_GLITZ_AGL_SURFACE
+LDADDS += $(GLITZ_AGL_LIBS)
+endif
+if CAIRO_CAN_TEST_GLITZ_EGL_SURFACE
+LDADDS += $(GLITZ_EGL_LIBS)
+endif
+if CAIRO_CAN_TEST_GLITZ_GLX_SURFACE
+LDADDS += $(GLITZ_GLX_LIBS)
+endif
+if CAIRO_CAN_TEST_GLITZ_WGL_SURFACE
+LDADDS += $(GLITZ_WGL_LIBS)
+endif
+
+
if HAVE_PTHREAD
LDADDS += -lpthread
endif