summaryrefslogtreecommitdiff
path: root/sys/directsound/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sys/directsound/meson.build')
-rw-r--r--sys/directsound/meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys/directsound/meson.build b/sys/directsound/meson.build
index eed3ffdf8..4b2144b1e 100644
--- a/sys/directsound/meson.build
+++ b/sys/directsound/meson.build
@@ -1,14 +1,22 @@
directsoundsink_sources = [
'gstdirectsoundsink.c',
+ 'gstdirectsounddevice.c',
'gstdirectsoundplugin.c',
]
+directsoundsink_device_flags = [
+ '-DGstDirectSoundDeviceProvider=GstDirectSoundSinkDeviceProvider',
+ '-DGstDirectSoundDeviceProviderClass=GstDirectSoundSinkDeviceProviderClass',
+ '-DGstDirectSoundDevice=GstDirectSoundSinkDevice',
+ '-DGstDirectSoundDeviceClass=GstDirectSoundSinkDeviceClass',
+]
+
if host_machine.system() == 'windows' and cc.has_header('dsound.h')
directsoundsink_dep = [cc.find_library('dsound'), cc.find_library('winmm'), cc.find_library('ole32')]
gstdirectsoundsink = library('gstdirectsound',
directsoundsink_sources,
- c_args : gst_plugins_good_args,
+ c_args : gst_plugins_good_args + directsoundsink_device_flags,
include_directories : [configinc],
dependencies : [gstaudio_dep] + directsoundsink_dep,
install : true,