summaryrefslogtreecommitdiff
path: root/tests/icles/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2010-05-11 16:08:21 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2010-05-11 19:02:55 +0100
commit1732ce033a71ed3d976f038b0e6f680968862711 (patch)
treedc24fcc7717ee38e801a3e5b8e17127a7d33b837 /tests/icles/Makefile.am
parent02a226f74604bee8d0ec0d582f9f330af55cd19a (diff)
Move oss4 plugin from -bad to -good
Hook up build infrastructure, docs and tests. Fixes #614305.
Diffstat (limited to 'tests/icles/Makefile.am')
-rw-r--r--tests/icles/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/tests/icles/Makefile.am b/tests/icles/Makefile.am
index a0d57a0ee..4405ecfb0 100644
--- a/tests/icles/Makefile.am
+++ b/tests/icles/Makefile.am
@@ -18,6 +18,17 @@ else
V4L2_TESTS =
endif
+if USE_OSS4
+OSS4_TESTS=test-oss4
+
+test_oss4_SOURCES = test-oss4.c
+test_oss4_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
+test_oss4_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgstinterfaces-0.10 $(GST_LIBS)
+test_oss4_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+else
+OSS4_TESTS=
+endif
+
if USE_X
X_TESTS = ximagesrc-test
@@ -40,5 +51,5 @@ videocrop2_test_SOURCES = videocrop2-test.c
videocrop2_test_CFLAGS = $(GST_CFLAGS)
videocrop2_test_LDADD = $(GST_LIBS)
-noinst_PROGRAMS = $(GTK_TESTS) $(V4L2_TESTS) $(X_TESTS) videocrop-test videobox-test videocrop2-test
+noinst_PROGRAMS = $(GTK_TESTS) $(OSS4_TESTS) $(V4L2_TESTS) $(X_TESTS) videocrop-test videobox-test videocrop2-test