summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrad Smith <brad@comstyle.com>2015-01-07 21:52:17 -0500
committerNicolas Dufresne <nicolas.dufresne@collabora.co.uk>2015-01-08 09:03:30 -0500
commit133bad7feea0659f34e9975a9b6372e8159129c4 (patch)
tree391574f3885560a76d292d283ba3d911614a0aa9 /configure.ac
parentff5b235c32f91c08ba9ada6b5a6bfd118debbf54 (diff)
v4l2: Add support for detecting the presence of V4L2 support on OpenBSD
https://bugzilla.gnome.org/review?bug=742503
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6a395c0a2..9a286c2b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -506,7 +506,10 @@ AG_GST_CHECK_FEATURE(GST_V4L2, [Video 4 Linux 2], video4linux2, [
AC_MSG_CHECKING([Checking for video4linux2 header ...])
AC_CHECK_HEADER(linux/videodev2.h, [ HAVE_GST_V4L2=yes ],
[
- AC_CHECK_HEADER(sys/videodev2.h, [ HAVE_GST_V4L2=yes ])
+ AC_CHECK_HEADER(sys/videodev2.h, [ HAVE_GST_V4L2=yes ],
+ [
+ AC_CHECK_HEADER(sys/videoio.h, [ HAVE_GST_V4L2=yes ])
+ ])
])
if test "x$HAVE_VIDEODEV" = "xno"; then
AC_MSG_WARN([video4linux2 was not found])