summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2013-06-13 12:40:15 +0530
committerArun Raghavan <arun.raghavan@collabora.co.uk>2013-06-13 12:44:32 +0530
commit01457027e0d384aca3e551ae684e0aa074ee5498 (patch)
tree2d5a70a0bb708bd1af38ff964d6ce25113769597 /configure.ac
parent01cc493944d1c0036d80243bea4d63ea79c33013 (diff)
pulsesink: Make 2.0 dependency optional
The getcaps function we added uses some pa_format_info_get_prop... accessor functions that were only added in 2.0, so we only have our getcaps implementation exist if we're compiling against libpulse 2.0 or above. Eventually, we could bump the minimum requirement to 2.0 or above. https://bugzilla.gnome.org/show_bug.cgi?id=686459
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8f398c28f..e599a71a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -813,6 +813,11 @@ AG_GST_CHECK_FEATURE(PULSE, [pulseaudio plug-in], pulseaudio, [
AC_CHECK_HEADERS([process.h])
AG_GST_PKG_CHECK_MODULES(PULSE, libpulse >= 1.0)
+ AG_GST_PKG_CHECK_MODULES(PULSE_2_0, libpulse >= 2.0)
+ if test x$HAVE_PULSE_2_0 = xyes; then
+ AC_DEFINE(HAVE_PULSE_2_0, 1, [defined if pulseaudio >= 2.0 is available])
+ fi
+
])
dnl *** dv1394 ***