summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2009-09-05 00:08:20 +0100
committerDamien Lespiau <damien.lespiau@intel.com>2009-09-05 00:23:55 +0100
commitc3f5fd7f51502e886791a1b76574a769a9e38524 (patch)
tree5d8fe1f4f43d7b8f13a02c8f22701ff4b921a191 /tests/Makefile.am
parent4162ad998584593af0cff252766b31ea2f1bded8 (diff)
[tests] Add an alpha test
The purpose of this test is to verify that we can now blend a video into a scene using the glColor of underlying actor.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am45
1 files changed, 27 insertions, 18 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ace8bfe..f62de48 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,31 +1,40 @@
NULL = #
-noinst_PROGRAMS = test-yuv-upload \
- test-rgb-upload \
- test-start-stop \
- $(NULL)
+noinst_PROGRAMS = \
+ test-alpha \
+ test-rgb-upload \
+ test-start-stop \
+ test-yuv-upload \
+ $(NULL)
INCLUDES = -I$(top_srcdir) \
$(MAINTAINER_CFLAGS) \
$(NULL)
-test_yuv_upload_SOURCES = test-yuv-upload.c
-test_yuv_upload_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
-test_yuv_upload_LDFLAGS = \
- $(CLUTTER_GST_LIBS) \
- $(GST_LIBS) \
- $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la
+test_alpha_SOURCES = test-alpha.c
+test_alpha_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
+test_alpha_LDFLAGS = \
+ $(CLUTTER_GST_LIBS) \
+ $(GST_LIBS) \
+ $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la
test_rgb_upload_SOURCES = test-rgb-upload.c
test_rgb_upload_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
-test_rgb_upload_LDFLAGS = \
- $(CLUTTER_GST_LIBS) \
- $(GST_LIBS) \
- $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la
+test_rgb_upload_LDFLAGS = \
+ $(CLUTTER_GST_LIBS) \
+ $(GST_LIBS) \
+ $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la
test_start_stop_SOURCES = test-start-stop.c
test_start_stop_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
-test_start_stop_LDFLAGS = \
- $(CLUTTER_GST_LIBS) \
- $(GST_LIBS) \
- $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la
+test_start_stop_LDFLAGS = \
+ $(CLUTTER_GST_LIBS) \
+ $(GST_LIBS) \
+ $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la
+
+test_yuv_upload_SOURCES = test-yuv-upload.c
+test_yuv_upload_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS)
+test_yuv_upload_LDFLAGS = \
+ $(CLUTTER_GST_LIBS) \
+ $(GST_LIBS) \
+ $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la