summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Byer <bbyer@bbyer.local>2007-11-16 05:04:54 -0800
committerJeremy Huddleston <jeremy@tifa.local>2007-11-19 02:38:24 -0800
commit213b51710c4a060ec5f04d1c96c82a5ba933cea9 (patch)
treed2e7c450268945e89dfff150b795b7e165487ce5 /configure.ac
parent815bf67416f65f935fdadd4640e59b5443d33ef9 (diff)
From Jeremy Huddleston:
1) Fixed a bug where XQUARTZ was #defined when auto but not when --enable-xquartz 2) Cleaned up missing #includes and function prototypes. 3) Fixed some invalid C syntax problems 4) Removed a bunch of dead code 5) Cleaned up code to prevent some warnings 6) Bugfix in xpr/x-hook.c - looks like someone just forgot to finish writing code for hook_remove()... I only noticed it because gcc -Wall complained about reaching the end of a non-void function... lucky for us gcc is smarter than we are.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 1eaf6ad27..ab6b86669 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1610,7 +1610,6 @@ if test "X$XQUARTZ" = Xauto; then
LDFLAGS=$save_LDFLAGS])
if test "X$xorg_cv_Carbon_framework" = Xyes; then
- AC_DEFINE([XQUARTZ],[1],[Have Quartz])
XQUARTZ=yes
else
XQUARTZ=no
@@ -1618,15 +1617,7 @@ if test "X$XQUARTZ" = Xauto; then
fi
if test "x$XQUARTZ" = xyes; then
- if test "x$X11APP" = xauto; then
- AC_MSG_CHECKING([whether to build X11.app])
- if test "x$XQUARTZ" = xyes ; then
- X11APP=yes
- else
- X11APP=no
- fi
- AC_MSG_RESULT([$X11APP])
- fi
+ AC_DEFINE([XQUARTZ],[1],[Have Quartz])
# glxAGL / glxCGL don't work yet
# AC_CACHE_CHECK([for AGL framework],xorg_cv_AGL_framework,[
@@ -1669,6 +1660,16 @@ if test "x$XQUARTZ" = xyes; then
fi
fi
+if test "x$X11APP" = xauto; then
+ AC_MSG_CHECKING([whether to build X11.app])
+ if test "x$XQUARTZ" = xyes ; then
+ X11APP=yes
+ else
+ X11APP=no
+ fi
+ AC_MSG_RESULT([$X11APP])
+fi
+
if test "x$LAUNCHD" = xauto; then
# Do we want to have this default to on for Xquartz builds only or any time we have launchd (like Xnest or Xvfb on OS-X)
#AC_CHECK_PROG(LAUNCHD, [launchd], [yes], [no])