summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoerg Sonnenberger <joerg@britannica.bec.de>2008-03-21 11:41:49 +0800
committerZhenyu Wang <zhenyu.z.wang@intel.com>2008-03-21 11:41:49 +0800
commite8da1a5418ab240ae7b1ef95bfea6bee22f1e0c1 (patch)
treea40d1271cea7df11fb3515961a0692069552d4b5 /configure.ac
parent224c36cc14a7552bc5df793ad582f0ea5349eb1e (diff)
Fix DRI config for NetBSD
Reported by Joerg. This does a little more clearn up.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0ea974f7..5b677f01 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,7 +87,8 @@ sdkdir=$(pkg-config --variable=sdkdir xorg-server)
# Checks for header files.
AC_HEADER_STDC
-if test "$DRI" != no; then
+AC_MSG_CHECKING([whether to include DRI support])
+if test x$DRI = xauto; then
AC_CHECK_FILE([${sdkdir}/dri.h],
[have_dri_h="yes"], [have_dri_h="no"])
AC_CHECK_FILE([${sdkdir}/sarea.h],
@@ -96,10 +97,7 @@ if test "$DRI" != no; then
[have_dristruct_h="yes"], [have_dristruct_h="no"])
AC_CHECK_FILE([${sdkdir}/damage.h],
[have_damage_h="yes"], [have_damage_h="no"])
-fi
-AC_MSG_CHECKING([whether to include DRI support])
-if test x$DRI = xauto; then
if test "$have_dri_h" = yes -a \
"$have_sarea_h" = yes -a \
"$have_dristruct_h" = yes; then