summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2007-10-01 16:09:13 -0700
committerEric Anholt <eric@anholt.net>2007-10-01 16:09:13 -0700
commit219354af212c7b68c20df689692c55331e36a705 (patch)
treebefeddc9c2ee6c903d3a171b42485d0f4ef30115 /configure.ac
parent1b83e5e589105d05c1b78032fa47eecee478cb99 (diff)
Restore building of pciaccess-based tools even if the server doesn't use it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1c7ad04f..e5a7cf6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,9 +116,15 @@ CFLAGS="$save_CFLAGS"
if test x$XSERVER_LIBPCIACCESS = xyes; then
PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.8.0])
+else
+ PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.5.0],
+ have_libpciaccess=yes,
+ have_libpciaccess=no)
fi
-
+have_libpciaccess=no
AM_CONDITIONAL(XSERVER_LIBPCIACCESS, test "x$XSERVER_LIBPCIACCESS" = xyes)
+AM_CONDITIONAL(LIBPCIACCESS,
+ test "x$XSERVER_LIBPCIACCESS" = xyes -o "x$have_libpciaccess" = xyes)
AM_CONDITIONAL(XMODES, test "x$XMODES" = xno)
if test "x$XSERVER_SOURCE" = x; then