summaryrefslogtreecommitdiff
path: root/wrappers/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Fonseca <jfonseca@vmware.com>2015-02-04 16:05:10 +0000
committerJosé Fonseca <jfonseca@vmware.com>2015-02-04 16:15:49 +0000
commit9614a9d92d7a2b216500b4dcc38294ba5ee5884b (patch)
tree46366ac338956320101145c4cd0bbf03fde48b2b /wrappers/CMakeLists.txt
parenta536a1fec54b9e2a9ae4fd2e69c2336f12559730 (diff)
cmake: Fail glxtrace/egltrace link if there are missing symbols.
Note, this is already the default for wgltrace/cgltrace.
Diffstat (limited to 'wrappers/CMakeLists.txt')
-rw-r--r--wrappers/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/wrappers/CMakeLists.txt b/wrappers/CMakeLists.txt
index 170681eb..5302853d 100644
--- a/wrappers/CMakeLists.txt
+++ b/wrappers/CMakeLists.txt
@@ -325,8 +325,9 @@ elseif (X11_FOUND)
# avoid the default "lib" prefix
PREFIX ""
# Prevent symbol relocations internal to our wrapper library to be
- # overwritten by the application.
- LINK_FLAGS "-Wl,-Bsymbolic -Wl,-Bsymbolic-functions"
+ # overwritten by the application. And fail if there are missing
+ # symbols.
+ LINK_FLAGS "-Wl,-Bsymbolic -Wl,-Bsymbolic-functions -Wl,-z,defs"
)
target_link_libraries (glxtrace
@@ -374,8 +375,9 @@ if (ENABLE_EGL AND NOT WIN32 AND NOT APPLE)
# avoid the default "lib" prefix
PREFIX ""
# Prevent symbol relocations internal to our wrapper library to be
- # overwritten by the application.
- LINK_FLAGS "-Wl,-Bsymbolic -Wl,-Bsymbolic-functions"
+ # overwritten by the application. And fail if there are missing
+ # symbols.
+ LINK_FLAGS "-Wl,-Bsymbolic -Wl,-Bsymbolic-functions -Wl,-z,defs"
)
target_link_libraries (egltrace