summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Fonseca <jose.r.fonseca@gmail.com>2012-12-09 15:46:59 +0000
committerJosé Fonseca <jose.r.fonseca@gmail.com>2012-12-09 15:46:59 +0000
commitc76fc373508945f419e56b3736f9fb2c8e088ad2 (patch)
tree7bb2b5f46c75728fe40a31bf11cbbfeeb9adebff /CMakeLists.txt
parentdb3491e272f3754676673d52c89238e9cc43b7ad (diff)
cmake: Move the binary/installs definitions to CLI.
As that's the only place they are used.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4963bd5c..549d0665 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -268,18 +268,6 @@ endif ()
set (SCRIPTS_INSTALL_DIR ${LIB_INSTALL_DIR}/scripts)
set (WRAPPER_INSTALL_DIR ${LIB_ARCH_INSTALL_DIR}/wrappers)
-# Expose the binary/install directories to source
-#
-# TODO: Use the same directory layout, for both build and install directories,
-# so that binaries can find each other using just relative paths.
-#
-add_definitions(
- -DAPITRACE_INSTALL_PREFIX="${CMAKE_INSTALL_PREFIX}"
- -DAPITRACE_PROGRAMS_INSTALL_DIR="${CMAKE_INSTALL_PREFIX}/bin"
- -DAPITRACE_SCRIPTS_INSTALL_DIR="${CMAKE_INSTALL_PREFIX}/${SCRIPTS_INSTALL_DIR}"
- -DAPITRACE_WRAPPERS_INSTALL_DIR="${CMAKE_INSTALL_PREFIX}/${WRAPPER_INSTALL_DIR}"
-)
-
##############################################################################
# Common libraries / utilities