summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2011-12-02 13:44:40 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2011-12-02 16:36:09 +0100
commitae0b95039949fc94523490dc62940d0626a240f7 (patch)
tree5d824a20946dd8f76b64ab708a039a824bb2663b /configure.ac
parentdee8fe83a917412b2c641b5b13be0a0fa2c8d32a (diff)
build: fix linking with -Wl,--as-needed -Wl,--no-undefined etc..
Mageia is using linker flags and miss symbols when linking. The error can be reproduced with: make LDFLAGS="-Wl,--as-needed -Wl,--no-undefined -Wl,-z,relro -Wl,-O1 -Wl,--build-id -Wl,--enable-new-dtags" Based on patch by Christophe Fergeau. https://bugs.freedesktop.org/show_bug.cgi?id=43416
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4a94d7b..e38aad1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -266,7 +266,7 @@ AC_SUBST(PULSE_CFLAGS)
AC_SUBST(PULSE_LIBS)
AS_IF([test "x$with_audio" = "xgstreamer"],
- [PKG_CHECK_MODULES(GST, gstreamer-0.10 gstreamer-base-0.10 gstreamer-app-0.10, [have_gst=yes GST_LIBS="$GST_LIBS -lgstapp-0.10 -lgstaudio-0.10"], [have_gst=no])],
+ [PKG_CHECK_MODULES(GST, gstreamer-0.10 gstreamer-base-0.10 gstreamer-app-0.10 gstreamer-audio-0.10, [have_gst=yes], [have_gst=no])],
[have_gst=no])
AS_IF([test "x$have_gst" = "xyes"],