summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-16 17:12:20 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2012-03-16 17:15:03 +0100
commit0c11bfc9d589e6e1073c34c0b22f4115c9ae37a9 (patch)
tree74e7dc4f9129de26a57fb907db0b5e1c5b99bab3 /configure.ac
parent837b98d043d10b1d6360d8e1079f88606b37ac84 (diff)
build-sys: if stow is installed, default prefix to it
This is going to make life easier for stow users, including myself.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 760736a..1ac291f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,13 @@ if test "x$ac_cv_prog_cc_c99" = xno; then
AC_MSG_ERROR([C99 compiler is required.])
fi
+
+AC_CHECK_PROG([STOW], [stow], [yes], [no])
+AS_IF([test "x$STOW" = "xyes" && test -d /usr/local/stow], [
+ AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME} ***])
+ ac_default_prefix="/usr/local/stow/${PACKAGE_NAME}"
+])
+
AC_PROG_INSTALL
AC_CANONICAL_HOST
AC_PROG_LIBTOOL