summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeff Smith <whydoubt@yahoo.com>2010-03-12 18:55:09 -0600
committerDan Nicholson <dbn.lists@gmail.com>2010-04-19 20:21:57 -0700
commit3b693fd93fbddc24360ed345a832387834e0a1fc (patch)
tree0f8544fc9e285d776bc264a3d7d0ea5566fe6504 /configure.ac
parent0a18cdb0ed2f4b747688f653d9947d174fae77ff (diff)
Use X_LIBS from pkg-config, instead of libdir, for locating libX11
Signed-off-by: Jeff Smith <whydoubt@yahoo.com> Signed-off-by: Dan Nicholson <dbn.lists@gmail.com> (cherry picked from commit 8d86d395dcf6a5f192b6987485bb7aef49f1fefc)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 61487c3905..5f3d02d567 100644
--- a/configure.ac
+++ b/configure.ac
@@ -547,7 +547,9 @@ else
x11_pkgconfig=no
fi
dnl Use the autoconf macro if no pkg-config files
-if test "$x11_pkgconfig" = no; then
+if test "$x11_pkgconfig" = yes; then
+ PKG_CHECK_MODULES([X], [x11])
+else
AC_PATH_XTRA
fi