summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-09-08 17:51:33 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2009-09-08 17:51:33 +0100
commit9389cb78a8ea5b6579d091ab1030ab9f1b13efc2 (patch)
treeb5213d8be51e80d1c372336860483734a53cac90 /test/Makefile.am
parent45759e5a0fb20a632f66a8dd206833b55a95f840 (diff)
[build] Improve handling of missing test apparatus
Improve detection, reporting and disabling of test backends when we lack the required libraries and utilities.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index fafeb436..d6bcb277 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -54,6 +54,7 @@ test_sources += $(multi_page_surface_test_sources)
endif
# Include fallback-resolution (once!) if we have any of the vector surfaces
+if BUILD_ANY2PPM
if CAIRO_HAS_SVG_SURFACE
test = $(fallback_resolution_test_sources)
endif
@@ -63,6 +64,7 @@ endif
if CAIRO_HAS_PS_SURFACE
test = $(fallback_resolution_test_sources)
endif
+endif
test_sources += $(test)
TESTS += cairo-test-suite$(EXEEXT)