summaryrefslogtreecommitdiff
path: root/xc/extras/Mesa/xdemos/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xc/extras/Mesa/xdemos/Makefile.am')
-rw-r--r--xc/extras/Mesa/xdemos/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/xc/extras/Mesa/xdemos/Makefile.am b/xc/extras/Mesa/xdemos/Makefile.am
new file mode 100644
index 000000000..dcdfa1bc6
--- /dev/null
+++ b/xc/extras/Mesa/xdemos/Makefile.am
@@ -0,0 +1,27 @@
+## Process this file with automake to produce Makefile.in
+
+#AUTOMAKE_OPTIONS = no-dependencies
+
+INCLUDES = -I$(top_srcdir)/include $(GLUT_CFLAGS) $(X_CFLAGS) $(SVGA_CFLAGS)
+
+if HAVE_SVGA
+SVGA_PROG = vgears vindex vtest
+endif
+
+EXTRA_PROGRAMS = shape xfont
+
+check_PROGRAMS = glthreads glxdemo glxheads glxinfo glxpixmap manywin offset \
+ xdemo wincopy $(SVGA_PROG)
+
+LDADD = $(GLUT_LIBS) $(top_builddir)/src-glu/libGLU.la \
+ $(top_builddir)/src/libGL.la -lm
+LDFLAGS = -no-install
+
+# execute all programs
+exec: $(check_PROGRAMS)
+ @for prog in $(check_PROGRAMS); \
+ do \
+ echo -n "Running $$prog ..." ; \
+ ./$$prog ; \
+ echo ; \
+ done