summaryrefslogtreecommitdiff
path: root/GL/mesa/tnl/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2006-03-30 20:08:44 +0000
committerKristian Høgsberg <krh@redhat.com>2006-03-30 20:08:44 +0000
commit8ec42a10ff04e51e8d0b4cffb15064d901bc398d (patch)
tree2af06be9148f62d706160087622d22908f5cea48 /GL/mesa/tnl/Makefile.am
parent08e319091fae7a60ae9fa757659cfde2966af9e9 (diff)
Mark the ARGB FBConfig as nonconforming to prevent drivers and apps from
falling over. Add @GLX_DEFINES@ so GLcore gets compiled with TLS support if configured. Only destroy the mesa buffer if it got initialized.
Diffstat (limited to 'GL/mesa/tnl/Makefile.am')
-rw-r--r--GL/mesa/tnl/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/GL/mesa/tnl/Makefile.am b/GL/mesa/tnl/Makefile.am
index 0f28ceeb5..cbf46fda3 100644
--- a/GL/mesa/tnl/Makefile.am
+++ b/GL/mesa/tnl/Makefile.am
@@ -1,6 +1,11 @@
noinst_LTLIBRARIES = libtnl.la
-AM_CFLAGS = $(DIX_CFLAGS) @SERVER_DEFINES@ @MODULE_DEFINES@ @LOADER_DEFINES@
+AM_CFLAGS = \
+ $(DIX_CFLAGS) \
+ @SERVER_DEFINES@ \
+ @MODULE_DEFINES@ \
+ @LOADER_DEFINES@ \
+ @GLX_DEFINES@
INCLUDES = -I@MESA_SOURCE@/include \
-I../X \