summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGurkirpal Singh <gurkirpal204@gmail.com>2017-08-12 21:37:15 +0530
committerChristian König <christian.koenig@amd.com>2017-09-15 14:28:36 +0200
commit6a8aa11c207b99920b9306b209f071a0e3fe8b43 (patch)
tree2c5d2ff8ff7abc6b360823915fffd2dcda280cb2 /configure.ac
parentacbfcb7105ddc1475c1ffb354605c0337008d001 (diff)
st/omx_bellagio: Rename state tracker and option
Changes --enable-omx option to --enable-omx-bellagio Signed-off-by: Gurkirpal Singh <gurkirpal204@gmail.com> Reviewed-and-Tested-by: Julien Isorce <julien.iso...@gmail.com> Acked-by: Christian König <christian.koenig@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 27 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index d0d4c0dfd1d..605c9b4e992 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1228,9 +1228,14 @@ AC_ARG_ENABLE([vdpau],
[enable_vdpau=auto])
AC_ARG_ENABLE([omx],
[AS_HELP_STRING([--enable-omx],
- [enable OpenMAX library @<:@default=disabled@:>@])],
- [enable_omx="$enableval"],
- [enable_omx=no])
+ [DEPRECATED: Use --enable-omx-bellagio instead @<:@default=auto@:>@])],
+ [AC_MSG_ERROR([--enable-omx is deprecated. Use --enable-omx-bellagio instead.])],
+ [])
+AC_ARG_ENABLE([omx-bellagio],
+ [AS_HELP_STRING([--enable-omx-bellagio],
+ [enable OpenMAX Bellagio library @<:@default=disabled@:>@])],
+ [enable_omx_bellagio="$enableval"],
+ [enable_omx_bellagio=no])
AC_ARG_ENABLE([va],
[AS_HELP_STRING([--enable-va],
[enable va library @<:@default=auto@:>@])],
@@ -1281,7 +1286,7 @@ if test "x$enable_opengl" = xno -a \
"x$enable_xa" = xno -a \
"x$enable_xvmc" = xno -a \
"x$enable_vdpau" = xno -a \
- "x$enable_omx" = xno -a \
+ "x$enable_omx_bellagio" = xno -a \
"x$enable_va" = xno -a \
"x$enable_opencl" = xno; then
AC_MSG_ERROR([at least one API should be enabled])
@@ -2126,8 +2131,8 @@ if test -n "$with_gallium_drivers" -a "x$with_gallium_drivers" != xswrast; then
PKG_CHECK_EXISTS([vdpau >= $VDPAU_REQUIRED], [enable_vdpau=yes], [enable_vdpau=no])
fi
- if test "x$enable_omx" = xauto -a "x$have_omx_platform" = xyes; then
- PKG_CHECK_EXISTS([libomxil-bellagio >= $LIBOMXIL_BELLAGIO_REQUIRED], [enable_omx=yes], [enable_omx=no])
+ if test "x$enable_omx_bellagio" = xauto -a "x$have_omx_platform" = xyes; then
+ PKG_CHECK_EXISTS([libomxil-bellagio >= $LIBOMXIL_BELLAGIO_REQUIRED], [enable_omx_bellagio=yes], [enable_omx_bellagio=no])
fi
if test "x$enable_va" = xauto -a "x$have_va_platform" = xyes; then
@@ -2138,7 +2143,7 @@ fi
if test "x$enable_dri" = xyes -o \
"x$enable_xvmc" = xyes -o \
"x$enable_vdpau" = xyes -o \
- "x$enable_omx" = xyes -o \
+ "x$enable_omx_bellagio" = xyes -o \
"x$enable_va" = xyes; then
need_gallium_vl=yes
fi
@@ -2146,7 +2151,7 @@ AM_CONDITIONAL(NEED_GALLIUM_VL, test "x$need_gallium_vl" = xyes)
if test "x$enable_xvmc" = xyes -o \
"x$enable_vdpau" = xyes -o \
- "x$enable_omx" = xyes -o \
+ "x$enable_omx_bellagio" = xyes -o \
"x$enable_va" = xyes; then
PKG_CHECK_MODULES([VL], [x11-xcb xcb xcb-dri2 >= $XCBDRI2_REQUIRED])
need_gallium_vl_winsys=yes
@@ -2172,14 +2177,14 @@ if test "x$enable_vdpau" = xyes; then
fi
AM_CONDITIONAL(HAVE_ST_VDPAU, test "x$enable_vdpau" = xyes)
-if test "x$enable_omx" = xyes; then
+if test "x$enable_omx_bellagio" = xyes; then
if test "x$have_omx_platform" != xyes; then
AC_MSG_ERROR([OMX requires at least one of the x11 or drm platforms])
fi
- PKG_CHECK_MODULES([OMX], [libomxil-bellagio >= $LIBOMXIL_BELLAGIO_REQUIRED])
- gallium_st="$gallium_st omx"
+ PKG_CHECK_MODULES([OMX_BELLAGIO], [libomxil-bellagio >= $LIBOMXIL_BELLAGIO_REQUIRED])
+ gallium_st="$gallium_st omx_bellagio"
fi
-AM_CONDITIONAL(HAVE_ST_OMX, test "x$enable_omx" = xyes)
+AM_CONDITIONAL(HAVE_ST_OMX_BELLAGIO, test "x$enable_omx_bellagio" = xyes)
if test "x$enable_va" = xyes; then
if test "x$have_va_platform" != xyes; then
@@ -2341,15 +2346,15 @@ AC_ARG_WITH([vdpau-libdir],
[VDPAU_LIB_INSTALL_DIR='${libdir}/vdpau'])
AC_SUBST([VDPAU_LIB_INSTALL_DIR])
-dnl Directory for OMX libs
+dnl Directory for OMX_BELLAGIO libs
-AC_ARG_WITH([omx-libdir],
- [AS_HELP_STRING([--with-omx-libdir=DIR],
- [directory for the OMX libraries])],
- [OMX_LIB_INSTALL_DIR="$withval"],
- [OMX_LIB_INSTALL_DIR=`$PKG_CONFIG --exists libomxil-bellagio && \
- $PKG_CONFIG --define-variable=libdir=\$libdir --variable=pluginsdir libomxil-bellagio`])
-AC_SUBST([OMX_LIB_INSTALL_DIR])
+AC_ARG_WITH([omx-bellagio-libdir],
+ [AS_HELP_STRING([--with-omx-bellagio-libdir=DIR],
+ [directory for the OMX_BELLAGIO libraries])],
+ [OMX_BELLAGIO_LIB_INSTALL_DIR="$withval"],
+ [OMX_BELLAGIO_LIB_INSTALL_DIR=`$PKG_CONFIG --exists libomxil-bellagio && \
+ $PKG_CONFIG --define-variable=libdir=\$libdir --variable=pluginsdir libomxil-bellagio`])
+AC_SUBST([OMX_BELLAGIO_LIB_INSTALL_DIR])
dnl Directory for VA libs
@@ -2852,7 +2857,7 @@ AC_CONFIG_FILES([Makefile
src/gallium/state_trackers/dri/Makefile
src/gallium/state_trackers/glx/xlib/Makefile
src/gallium/state_trackers/nine/Makefile
- src/gallium/state_trackers/omx/Makefile
+ src/gallium/state_trackers/omx_bellagio/Makefile
src/gallium/state_trackers/osmesa/Makefile
src/gallium/state_trackers/va/Makefile
src/gallium/state_trackers/vdpau/Makefile
@@ -2862,7 +2867,7 @@ AC_CONFIG_FILES([Makefile
src/gallium/targets/d3dadapter9/d3d.pc
src/gallium/targets/dri/Makefile
src/gallium/targets/libgl-xlib/Makefile
- src/gallium/targets/omx/Makefile
+ src/gallium/targets/omx-bellagio/Makefile
src/gallium/targets/opencl/Makefile
src/gallium/targets/opencl/mesa.icd
src/gallium/targets/osmesa/Makefile