summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2011-03-01 15:34:46 +0530
committerArun Raghavan <arun.raghavan@collabora.co.uk>2011-07-29 01:25:15 +0530
commita67b536741e330a15ce15d7efef585d6df9c23c4 (patch)
tree1ddfc85180a44aef084582a20477d2b276ab11b9 /configure.ac
parent379049809c86ed142564e53004a0f234c9959883 (diff)
pulsesink: Use the extended stream API if available
This uses the new extended API for creating streams. This will allow us to support compressed formats natively in pulsesink as well.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d6f2b9ba2..304feddc4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -839,6 +839,10 @@ AG_GST_CHECK_FEATURE(PULSE, [pulseaudio plug-in], pulseaudio, [
if test x$HAVE_PULSE_0_9_20 = xyes; then
AC_DEFINE(HAVE_PULSE_0_9_20, 1, [defined if pulseaudio >= 0.9.20 is available])
fi
+ AG_GST_PKG_CHECK_MODULES(PULSE_1_0, libpulse >= 0.98)
+ if test x$HAVE_PULSE_1_0 = xyes; then
+ AC_DEFINE(HAVE_PULSE_1_0, 1, [defined if pulseaudio >= 1.0 is available])
+ fi
])
dnl *** dv1394 ***