summaryrefslogtreecommitdiff
path: root/test/xi1/Makefile.am
diff options
context:
space:
mode:
authorMihail Konev <k.mvc@ya.ru>2017-01-12 13:21:07 +0500
committerAdam Jackson <ajax@redhat.com>2017-01-12 15:01:19 -0500
commitff66bca3e8797db709e03572d296358dc4b95653 (patch)
treee7e3eaa4e1d7773ac50b0b21994afe4ab5b63c2c /test/xi1/Makefile.am
parent45546219e117c1b6129fd9f9be2ce5b592486feb (diff)
tests: Refactor wraps into protocol-common.c
Part of refactoring the tests into a single binary, to make partial rebuild slightly faster and less verbose. Prepares for joining test/xi2/protocol-* into a single binary. Reviewed-by: Adam Jackson <ajax@redhat.com> Signed-off-by: Mihail Konev <k.mvc@ya.ru>
Diffstat (limited to 'test/xi1/Makefile.am')
-rw-r--r--test/xi1/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/xi1/Makefile.am b/test/xi1/Makefile.am
index 907fa7aea..b7060e7d4 100644
--- a/test/xi1/Makefile.am
+++ b/test/xi1/Makefile.am
@@ -10,6 +10,7 @@ AM_CFLAGS = $(DIX_CFLAGS) @XORG_CFLAGS@
AM_CPPFLAGS = @XORG_INCS@ -I$(srcdir)/../xi2
TEST_LDADD=../libxservertest.la $(XORG_SYS_LIBS) $(XSERVER_SYS_LIBS) $(GLX_SYS_LIBS)
COMMON_SOURCES=$(srcdir)/../xi2/protocol-common.c
+COMMON_LD_FLAGS = -Wl,-wrap,dixLookupWindow -Wl,-wrap,dixLookupClient
if SPECIAL_DTRACE_OBJECTS
TEST_LDADD += $(OS_LIB) $(DIX_LIB)
@@ -17,7 +18,7 @@ endif
protocol_xchangedevicecontrol_LDADD=$(TEST_LDADD)
-protocol_xchangedevicecontrol_LDFLAGS=$(AM_LDFLAGS) -Wl,-wrap,WriteToClient
+protocol_xchangedevicecontrol_LDFLAGS=$(COMMON_LD_FLAGS) -Wl,-wrap,WriteToClient
protocol_xchangedevicecontrol_SOURCES=$(COMMON_SOURCES) protocol-xchangedevicecontrol.c