summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2021-03-25 10:16:31 +0100
committerPovilas Kanapickas <povilas@radix.lt>2021-08-06 11:29:29 +0000
commita4ab57cb748674823744a8ef5a0b416ee553efe8 (patch)
treea09237eb3d75a48214dfb722175d9794027b9dd2 /meson.build
parent84897891e5e7eb44068cda22284dca70c6cfd1a2 (diff)
build: Add dependency on libxcvt
libxcvt is a library providing a standalone version of the X server implementation of the VESA CVT standard timing modelines generator. Closes: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1142 Signed-off-by: Olivier Fourdan <ofourdan@redhat.com> Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 24a3840e0..bdab9a9f3 100644
--- a/meson.build
+++ b/meson.build
@@ -192,6 +192,7 @@ if (host_machine.system() != 'darwin' and
endif
endif
xorgsdkdir = join_paths(get_option('prefix'), get_option('includedir'), 'xorg')
+libxcvt_dep = dependency('libxcvt', required: build_xorg)
build_xwayland = false
if (host_machine.system() != 'darwin' and
@@ -208,6 +209,7 @@ if (host_machine.system() != 'darwin' and
xwayland_dep = [
dependency('wayland-client', version: wayland_req, required: xwayland_required),
dependency('wayland-protocols', version: wayland_protocols_req, required: xwayland_required),
+ dependency('libxcvt', required: xwayland_required),
]
if build_glamor