summaryrefslogtreecommitdiff
path: root/Xi/Makefile.am
diff options
context:
space:
mode:
authorJasper St. Pierre <jstpierre@mecheye.net>2012-11-01 14:14:13 -0400
committerPeter Hutterer <peter.hutterer@who-t.net>2012-12-17 15:01:22 +1000
commit482e0cb35225dc3b0664f9429db19c61b0c98ef6 (patch)
tree02ae15a144ab9ae5b5cd1d2cb124854269f3bd1e /Xi/Makefile.am
parentb34cffd27b9ef46e1dd477219cbb90e36d5609e3 (diff)
cursor: Move pointer barrier code over to XI
In order to send events to specific windows associated with the barrier, we need to move the code that handles barriers to somewhere where it's easier to construct and send events. Rather than duplicating XSync with its XSyncSelectAlarm, re-use the existing XI infrastructure. For now, just move a bunch of code over, rename some things, and initialize the new structures, but still consider it a separate codebase. Pointer barrier requests are still handled by XFixes, so this is a weird intermediate state. It's unknown whether we'll add explicit requests to pointer barriers inside XI. Signed-off-by: Jasper St. Pierre <jstpierre@mecheye.net> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'Xi/Makefile.am')
-rw-r--r--Xi/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Xi/Makefile.am b/Xi/Makefile.am
index 69c7886b9..af85bd049 100644
--- a/Xi/Makefile.am
+++ b/Xi/Makefile.am
@@ -78,6 +78,8 @@ libXi_la_SOURCES = \
ungrdevk.h \
xiallowev.c \
xiallowev.h \
+ xibarriers.c \
+ xibarriers.h \
xichangecursor.c \
xichangecursor.h \
xichangehierarchy.c \