summaryrefslogtreecommitdiff
path: root/hw/kdrive/ephyr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/kdrive/ephyr/Makefile.am')
-rw-r--r--hw/kdrive/ephyr/Makefile.am62
1 files changed, 41 insertions, 21 deletions
diff --git a/hw/kdrive/ephyr/Makefile.am b/hw/kdrive/ephyr/Makefile.am
index 604e22eaa..d025c201c 100644
--- a/hw/kdrive/ephyr/Makefile.am
+++ b/hw/kdrive/ephyr/Makefile.am
@@ -3,47 +3,65 @@ INCLUDES = \
@KDRIVE_CFLAGS@ \
-I$(srcdir)/../../../exa
-noinst_LIBRARIES = libxephyr-hostx.a libxephyr-hostxv.a libxephyr.a
+if XV
+ LIBXEPHYR_HOSTXV=libxephyr-hostxv.a
+else
+ LIBXEPHYR_HOSTXV=
+endif
-bin_PROGRAMS = Xephyr
+if XEPHYR_HAS_DRI
+ LIBXEPHYR_HOSTDRI=libxephyr-hostdri.a
+else
+ LIBXEPHYR_HOSTDRI=
+endif
+
+noinst_LIBRARIES = libxephyr-hostx.a $(LIBXEPHYR_HOSTXV) $(LIBXEPHYR_HOSTDRI) libxephyr.a
+bin_PROGRAMS = Xephyr
libxephyr_hostx_a_SOURCES = \
hostx.c \
hostx.h
-libxephyr_hostx_a_INCLUDES = @XEPHYR_INCS@
+libxephyr_hostxv_a_INCLUDES = @XEPHYR_INCS@
+if XV
libxephyr_hostxv_a_SOURCES= \
ephyrhostvideo.c \
ephyrhostvideo.h
+endif
+
+if XEPHYR_HAS_DRI
+
+libxephyr_hostdri_a_SOURCES= \
+ephyrdriext.c \
+ephyrdri.c \
+ephyrdri.h \
+XF86dri.c \
+ephyrglxext.c \
+ephyrglxext.h \
+ephyrhostglx.c \
+ephyrhostglx.h
+
+libxephyr_hostdri_a_CFLAGS= \
+-I$(top_srcdir) \
+@LIBDRM_CFLAGS@ \
+@DRIPROTO_CFLAGS@
+
+endif
libxephyr_a_SOURCES = \
ephyr.c \
ephyr_draw.c \
ephyrvideo.c \
- XF86dri.c \
- ephyrdriext.c \
- ephyrdri.c \
- ephyrdri.h \
- ephyrglxext.c \
- ephyrglxext.h \
- ephyrhostglx.c \
- ephyrhostglx.h \
- ephyrhostproxy.c \
- ephyrhostproxy.h \
- ephyrhostproxy.c \
- ephyrproxyext.c \
- ephyrproxyext.h \
os.c \
hostx.h \
ephyr.h \
ephyrlog.h
libxephyr_a_CFLAGS = \
-@LIBDRM_CFLAGS@ \
-I$(top_srcdir) \
-@DRIPROTO_CFLAGS@
+@LIBDRM_CFLAGS@
Xephyr_SOURCES = \
ephyrinit.c
@@ -51,17 +69,19 @@ Xephyr_SOURCES = \
Xephyr_LDADD = \
libxephyr.a \
libxephyr-hostx.a \
- libxephyr-hostxv.a \
+ $(LIBXEPHYR_HOSTXV) \
+ $(LIBXEPHYR_HOSTDRI) \
../../../exa/libexa.la \
@KDRIVE_LIBS@ \
@XEPHYR_LIBS@ \
@LIBDRM_LIBS@ \
- -lGL
+ @XEPHYR_DRI_LIBS@
Xephyr_DEPENDENCIES = \
libxephyr.a \
libxephyr-hostx.a \
- libxephyr-hostxv.a \
+ $(LIBXEPHYR_HOSTXV) \
+ $(LIBXEPHYR_HOSTDRI) \
@KDRIVE_LOCAL_LIBS@
relink: