summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2009-07-28 14:19:24 +1000
committerDave Airlie <airlied@redhat.com>2009-07-28 14:19:24 +1000
commit0a168401c401727e49a12cae43a6a387b1f2928d (patch)
tree14009cae14ca6fe298933516c98e5d57344ddf8d /configure.ac
parentb3751454cbe02ee952bab213e8c3684d429c41b3 (diff)
pci: add support for pci is boot vga call.
This allows us to ask the kernel for the boot VGA device instead of nasty guessing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7c0ed602d..b245cdcc4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1387,6 +1387,7 @@ if test "x$XORG" = xyes; then
LIBS=$PCIACCESS_LIBS
AC_CHECK_FUNCS([pci_system_init_dev_mem])
AC_CHECK_FUNCS([pci_device_enable])
+ AC_CHECK_FUNCS([pci_device_is_boot_vga])
LIBS=$SAVE_LIBS
CFLAGS=$SAVE_CFLAGS
XORG_SYS_LIBS="$XORG_SYS_LIBS $PCIACCESS_LIBS $DLOPEN_LIBS $GLX_SYS_LIBS"