summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2013-11-20 11:22:04 -0800
committerKeith Packard <keithp@keithp.com>2013-11-20 14:14:58 -0800
commite390e3aaee3dace2a1e6cfe66efd884fc256b0f0 (patch)
treec9445900402899bca8e6beb6e6d2560d77954629 /src/Makefile.am
parentdaa78ee9a5f9b5590d540aa06466d6728fb2c795 (diff)
Provide pthread-based alternative implementation
This uses pthread mutexes and condition variables instead of futexes. Signed-off-by: Keith Packard <keithp@keithp.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0edf904..1a67bdd 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,15 +1,23 @@
lib_LTLIBRARIES = libxshmfence.la
+if PTHREAD
+PTHREAD_SOURCES=xshmfence_pthread.c xshmfence_pthread.h
+endif
+
+if FUTEX
FUTEX_SOURCES=xshmfence_futex.c xshmfence_futex.h
+endif
libxshmfence_la_SOURCES = \
xshmfenceint.h \
xshmfence_alloc.c \
+ $(PTHREAD_SOURCES) \
$(FUTEX_SOURCES)
AM_CFLAGS = $(CWARNFLAGS)
libxshmfence_la_LDFLAGS = -version-number 1:0:0 -no-undefined
+libxshmfence_la_LIBADD = @PTHREAD_LIBS@
libxshmfenceincludedir = $(includedir)/X11
libxshmfenceinclude_HEADERS = xshmfence.h