summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-28 14:17:12 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-28 14:17:12 +0000
commita18d9ec0c4bfa36460d5e3eba1c5fb8a90086500 (patch)
tree1473f7df63cf6149e2933b518a4ea84ef4b63706 /configure.ac
parentbcdcaebcd2127f4e7e1c368f341a781b4cf8af6b (diff)
Add encodings to fontenc build system, plus various fixes to make it
distcheck.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e4bf13..cf0cc3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,22 @@ AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_LIBTOOL
+# mkfontscale
+
+AC_PATH_PROG(MKFONTSCALE, mkfontscale)
+if [[ -z $MKFONTSCALE ]]; then
+ AC_MSG_ERROR([mkfontscale is needed to build fontenc. FIXME: when we
+ know where it is going to live, put a more informative
+ comment here])
+fi
+
+# gzip
+
+AC_PATH_PROG(GZIP, gzip)
+if [[ -z $GZIP ]]; then
+ AC_MSG_ERROR([gzip is needed to compress font encodings])
+fi
+
# Check for dependencies
PKG_CHECK_MODULES(DEP, x11)
@@ -40,5 +56,7 @@ AC_SUBST(DEP_CFLAGS)
AC_SUBST(DEP_LIBS)
AC_OUTPUT([Makefile
+ encodings/Makefile
+ encodings/large/Makefile
src/Makefile
fontenc.pc])