summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:45 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-14 00:25:45 +0000
commit91cc5c0c1d36059e6e0792a80b4443b8bb6c0c14 (patch)
tree2c8f49121c86256fc634227bddc725d03bf996ed /Makefile.am
parent68de46d260d44841aab5ecce9d31cf24ccd533f8 (diff)
Use sed to fill in variables in man page
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 32 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bce1bee..558e872 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,7 +90,7 @@ xfs_SOURCES = \
include/swaprep.h \
include/swapreq.h
-dist_man1_MANS = \
+appman_SOURCES = \
xfs.man
FSERRORS = /var/log/xfs.log
@@ -106,3 +106,34 @@ config_DATA = config
EXTRA_DIST = xfs.def config.cpp
CLEANFILES = config
+
+appmandir = $(mandir)/man$(APP_MAN_SUFFIX)
+
+appman_DATA = $(appman_SOURCES:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST += $(appman_SOURCES)
+CLEANFILES += $(appman_DATA)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@