summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-11-08 07:50:12 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-11-08 07:50:12 +0000
commit515ba1756966081ca3fae0cdd5a776f5a4fc6ad1 (patch)
tree0edecfd8a1af1e40bb443bcd52aeea7b4c7436a7 /configure.ac
parent3834f880ba013be524cd5b4ce4ff75734742ad12 (diff)
Changes to match bug #3180 checkin to monolith:
Generate Xsession from Xsession.cpp Add SHELL_CMD to cpp substitutions configure.ac Set SHELL_CMD to /bin/ksh for sco, /bin/sh for all other OS'es.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 24efc5c..2f557ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,6 +192,12 @@ AC_ARG_WITH(config-type,
[SERVERSTYPE="$withval"], [SERVERSTYPE="ws"])
AC_SUBST(SERVERSTYPE)
+case $host_os in
+ *sco*) SHELL_CMD="/bin/ksh" ;;
+ *) SHELL_CMD="/bin/sh" ;;
+esac
+AC_SUBST(SHELL_CMD)
+
# Checks for pkg-config packages
PKG_CHECK_EXISTS(xinerama, [
@@ -262,7 +268,7 @@ AC_SUBST(XDM_CFLAGS)
AC_SUBST(XDM_LIBS)
#
-# xmdshell
+# xdmshell
#
PKG_CHECK_MODULES(AUTH, xau)