summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-07-14 13:02:02 -0700
committerAlan Coopersmith <alanc@alf.(none)>2006-07-14 13:02:02 -0700
commit41211f8c849de67cebeb9d9f7516eb5a4a7eb3cf (patch)
tree36474cf7728960ce8802daedd3acdf6e3af1e377 /Makefile.am
parentbfe7bc6a04d468f7943ebed9a7ea571cbf916d9e (diff)
Add XORG_WITH_LINT & lint targets for checking code with lint/sparse/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d945683..1ebc23a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -164,3 +164,14 @@ appdefault_DATA = $(APPDEFAULTFILES)
CLEANFILES += $(APPDEFAULTFILES)
EXTRA_DIST += $(APPDEFAULTFILES:%=%.ad)
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(xdm_CFLAGS) $(xdm_SOURCES) $(xdm_LDADD)
+ $(LINT) $(ALL_LINT_FLAGS) $(xdmshell_CFLAGS) $(xdmshell_SOURCES)
+ $(LINT) $(ALL_LINT_FLAGS) $(chooser_CFLAGS) $(chooser_SOURCES) $(chooser_LDADD)
+ (cd greeter && $(MAKE) $(AM_MAKEFLAGS) lint)
+endif LINT