summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gentoo.org>2006-11-23 15:15:30 +0100
committerJosh Triplett <josh@freedesktop.org>2006-11-23 07:32:18 -0800
commit11738b2af0d8bfcf5b2f7c0d3e6ade1a14866b94 (patch)
treebb51d7cfb0224fff8623a79f2d0686bf49788f34 /src/Makefile.am
parent30c768b322f613d697a61997e081a19aecd0b07f (diff)
Avoid race condition when using multiple make jobs
Avoid race condition when symlinking XML files. When declaring a rule with many files as target, the rule is called when any of them is requested, resulting in multiple for loops happening during a make process using more than one job. Also, use '$(LN_S) -f' rather than removing and recreating a file, that one should be as supported as 'rm -f' and requires one less command.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fdbd6b4..b02caf3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -220,7 +220,4 @@ SUFFIXES = .xml
-o $@ $(srcdir)/c-client.xsl $<
$(EXTENSION_XML):
- for i in $(EXTENSION_XML) ; do \
- rm -f $$i ; \
- $(LN_S) $(XCBPROTO_XCBINCLUDEDIR)/$$i $$i ; \
- done
+ $(LN_S) -f $(XCBPROTO_XCBINCLUDEDIR)/$@ $@