summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2013-01-18 12:11:10 +0200
committerKristian Høgsberg <krh@bitplanet.net>2013-01-24 16:30:08 -0500
commita95efd3bb7911b4c24c6bd704b82623ee60b4d6c (patch)
tree99d0e218a34b0251796235cb98421983c9b7f1b1 /configure.ac
parenta87ccdc993b280e3523d306881740db1708fe7e2 (diff)
configure: remove C++ support
With the Android backend gone, there is no C++ code anymore. Remove support for C++ in the build. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index a2e8e275..f9075ae1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,7 +13,6 @@ AM_SILENT_RULES([yes])
# Check for programs
AC_PROG_CC
-AC_PROG_CXX
AC_PROG_SED
# Initialize libtool
@@ -257,14 +256,11 @@ PKG_CHECK_MODULES(SETBACKLIGHT, [libudev libdrm], enable_setbacklight=yes, enabl
AM_CONDITIONAL(BUILD_SETBACKLIGHT, test "x$enable_setbacklight" = "xyes")
if test "x$GCC" = "xyes"; then
- my_common_gcc_flags="-Wall -Wextra -Wno-unused-parameter \
- -Wno-missing-field-initializers -g -fvisibility=hidden"
- GCC_CFLAGS="$my_common_gcc_flags \
+ GCC_CFLAGS="-Wall -Wextra -Wno-unused-parameter \
+ -Wno-missing-field-initializers -g -fvisibility=hidden \
-Wstrict-prototypes -Wmissing-prototypes"
- GCC_CXXFLAGS="$my_common_gcc_flags"
fi
AC_SUBST(GCC_CFLAGS)
-AC_SUBST(GCC_CXXFLAGS)
if test "x$WESTON_NATIVE_BACKEND" = "x"; then
WESTON_NATIVE_BACKEND="drm-backend.so"