summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorQuentin Glidic <sardemff7+git@sardemff7.net>2016-06-23 21:00:31 +0200
committerQuentin Glidic <sardemff7+git@sardemff7.net>2017-01-16 16:22:13 +0100
commitdb776dbecfc806b9766ed39af8c91b3a99d975d2 (patch)
tree51ba795c431fc328610e7a710389394eef76d6a0 /configure.ac
parent46ffea638de6f099744f20f2485c6b5977422ef4 (diff)
editor: Drop g_type_init() call
HAVE_PANGO is not in any AC_DEFINE(), so the check is just wrong. g_type_init() was never called, which is fine since GLib 2.36 anyway. It is better not to have a wrong usage of HAVE_PANGO here. Just check for GLib 2.36 in configure.ac instead. Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9cad9036..363733d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -420,7 +420,7 @@ if test x$enable_clients = xyes; then
[AC_ERROR([cairo-egl not used because $CAIRO_EGL_PKG_ERRORS])])],
[have_cairo_egl=no])
- PKG_CHECK_MODULES(PANGO, [pangocairo], [have_pango=yes], [have_pango=no])
+ PKG_CHECK_MODULES(PANGO, [pangocairo pango glib-2.0 >= 2.36], [have_pango=yes], [have_pango=no])
fi
AC_ARG_ENABLE(resize-optimization,