summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-01-31 12:12:59 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2020-02-02 23:46:14 +0000
commit71830dd460b8c5ea8c8db5044f06ee1f826f22ca (patch)
tree94f4eb550d01734351d1861e23c15a116c14312d /meson.build
parent8705aba2eaf39ac1a31ccbcb6409e85a45c23be2 (diff)
tablet: fix the handling of axis updates after a forced proximity out
Where a pen was forced out of proximity and an eraser came into proximity without axis updates on the prox-in, subsequent axis updates would trigger the pen back into proximity. This resulted in two tools in proximity at once though the new pen never went out of proximity This would trigger crashes in various compositors/applications, see https://github.com/xournalpp/xournalpp/issues/1141#issuecomment-578362497 The cause was a wrong condition introduced in ffd8c71e4e. We only need to force the pen bit on if the current tool state is currently zero and no tool update was sent with the axis event. In our case, the tool state is nonzero already (eraser) and we can skip this bit. Fixes #418 Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f588862c..114148c1 100644
--- a/meson.build
+++ b/meson.build
@@ -785,6 +785,7 @@ if get_option('tests')
'test/litest-device-dell-canvas-totem.c',
'test/litest-device-dell-canvas-totem-touch.c',
'test/litest-device-elantech-touchpad.c',
+ 'test/litest-device-elan-tablet.c',
'test/litest-device-generic-singletouch.c',
'test/litest-device-gpio-keys.c',
'test/litest-device-huion-pentablet.c',