summaryrefslogtreecommitdiff
path: root/test/putsurface/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/putsurface/Makefile.am')
-rw-r--r--test/putsurface/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/test/putsurface/Makefile.am b/test/putsurface/Makefile.am
index 3e5c864..51edb25 100644
--- a/test/putsurface/Makefile.am
+++ b/test/putsurface/Makefile.am
@@ -22,13 +22,15 @@
bin_PROGRAMS = putsurface
-AM_CFLAGS = -I$(top_srcdir)/src -I$(top_srcdir)/src/x11 -DIN_LIBVA
+AM_CFLAGS = -I$(top_srcdir)/va -I$(top_srcdir)/src/x11
-TEST_LIBS = $(top_srcdir)/src/$(libvabackendlib)
+TEST_LIBS = $(top_srcdir)/va/$(libvabackendlib) -lpthread
putsurface_LDADD = $(TEST_LIBS)
putsurface_SOURCES = putsurface.c
+EXTRA_DIST = loadsurface.h
+
valgrind: $(bin_PROGRAMS)
for a in $(bin_PROGRAMS); do \