summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSiraj Razick <siraj.razick@collabora.co.uk>2012-01-02 13:12:08 -0500
committerJonny Lamb <jonny.lamb@collabora.co.uk>2012-01-03 10:59:25 +0000
commitb5bc31a5084e05d7e4251a37f628f7835928ab1c (patch)
tree19f8c58a77944bf429e8841bc4a31ec1d56a501f /configure.ac
parent3cdfbe659bbe3a7e217486c2b0a957880b3c24ea (diff)
Make gabble cross compile with mingw32
The patch provides the changes required to make gabble compile under mingw32. - Index is replaced with strchr since index is deprecated and not included in mingw32 sdk - D_WIN32_WINNT=0x0501 is defined to make getnameinfo work - And other compile fixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a43f0f223..3e8d53812 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,25 @@ TP_COMPILER_WARNINGS([ERROR_CFLAGS], [test "x$official_release" = xno],
unused-parameter])
AC_SUBST([ERROR_CFLAGS])
+
+#------------------------------------------------------------
+# Detect Operating system based on $host
+#------------------------------------------------------------
+AC_MSG_CHECKING([operating system])
+
+case "$host" in
+ *-*-*mingw*|*-*-*cygwin*)
+ platform=win32
+ AC_MSG_RESULT($platform)
+ ;;
+ *)
+ platform=unix
+ AC_MSG_RESULT($platform)
+ ;;
+esac
+
+AM_CONDITIONAL([WINDOWS], [test "$platform" = "win32"])
+
# -----------------------------------------------------------
# Make CA certificates path configurable
# Stolen from GIO's TLS