summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorcarlosg <carlosg>2006-05-16 15:03:57 +0000
committercarlosg <carlosg>2006-05-16 15:03:57 +0000
commitd2aa1ae17071ea6289bead36e7a27613e535545c (patch)
treefb89b28bf5ee31c4d38691815facc8788629f5c9 /Makefile.am
parente9b940071d7c926a6be6bb2aca0e38b2bddadbb2 (diff)
2006-05-15 Carlos Garnacho Parro <carlosg@gnome.org>
* Merged the waiting-the-dbus branch into HEAD * configure.in, Makefile.am, autogen.sh: bump to 1.9.0, do not use translations (no longer needed) and fix references to the new .pc file * GroupsConfig.pm, HostsConfig.pm, IfacesConfig.pm, NFSConfig.pm, NTPConfig.pm, SMBConfig.pm, ServicesConfig.pm, ServicesList.pm, SharesList.pm, SystemToolsBackends.pl.in, TimeConfig.pm, UsersConfig.pm, org.freedesktop.SystemToolsBackends.service.in, system-tools-backends-2.0.pc.in, test-backends, Init/Services.pm, Init/ServicesList.pm, Network/Hosts.pm, Network/Ifaces.pm, Shares/Exports.pm, Shares/NFS.pm, Shares/SMB.pm, Time/NTP.pm, Time/TimeDate.pm, Users/Groups.pm, Users/Shells.pm, Users/Users.pm, Utils/Backend.pm, Utils/File.pm, Utils/Monitor.pm, Utils/Parse.pm, Utils/Platform.pm, Utils/Replace.pm, Utils/Report.pm, Utils/Util.pm, Utils/XML.pm: Added/refactored files, replace the functionality in the older *.pl.in files * boot-conf.in, boot-grub.pl.in, boot-lilo.pl.in, boot-yaboot.pl.in, boot.pl.in, file.pl.in, general.pl.in, network-conf.in, network.pl.in, parse.pl.in, platform.pl.in, replace.pl.in, report.pl.in, service-list.pl.in, service.pl.in, services-conf.in, share.pl.in, shares-conf.in, system-tools-backends.pc.in, time-conf.in, users-conf.in, util.pl.in, xml.pl.in: Functional removed files, they've been replaced with the files above. * add_amp.sh, debug.pl.in, dhcpd-conf.in, dhcpd.pl.in, disks-conf.in, display-conf.in, filesys.pl.in, font-conf.in, font.pl.in, gen-reportcode-list.sh, guess_system.sh, hardware-conf.in, internetsharing-conf.in, ishare.pl.in, media.pl.in, memory-conf.in, mouse-conf.in, option.pl, package-conf.in, partition.pl.in, perldoc.pl, print-conf.in, print.pl.in, process.pl.in, removable-media.pl.in, rhprinterdb2gstxml.pl, test.pl, tokenizer.pl.in, type1inst, x.pl.in: Bunch of unused files (or used in unstable tools), if/when they prove their usefulness, they'll be added back, but for now they'd better be in the Attic.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am75
1 files changed, 22 insertions, 53 deletions
diff --git a/Makefile.am b/Makefile.am
index bb49856..367bd8a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,70 +1,39 @@
-SUBDIRS = m4macros files po
+SUBDIRS = m4macros files Init Network Shares Time Users Utils
-backends = \
- dhcpd-conf \
- disks-conf \
- memory-conf \
- network-conf \
- services-conf \
- shares-conf \
- time-conf \
- users-conf \
- boot-conf \
- print-conf \
- mouse-conf \
- internetsharing-conf \
- package-conf \
- display-conf \
- font-conf
+scripts = \
+ SystemToolsBackends.pl \
+ GroupsConfig.pm \
+ HostsConfig.pm \
+ IfacesConfig.pm \
+ NFSConfig.pm \
+ NTPConfig.pm \
+ ServicesConfig.pm \
+ SMBConfig.pm \
+ TimeConfig.pm \
+ UsersConfig.pm
-perl_libs = \
- boot.pl \
- boot-grub.pl \
- boot-lilo.pl \
- boot-yaboot.pl \
- dhcpd.pl \
- debug.pl \
- file.pl \
- filesys.pl \
- font.pl \
- general.pl \
- ishare.pl \
- media.pl \
- network.pl \
- parse.pl \
- partition.pl \
- platform.pl \
- print.pl \
- process.pl \
- replace.pl \
- report.pl \
- service.pl \
- service-list.pl \
- share.pl \
- tokenizer.pl \
- util.pl \
- x.pl \
- xml.pl
-
-scripts_SCRIPTS = $(backends) $(perl_libs) guess_system.sh type1inst
+scripts_SCRIPTS = $(scripts)
EXTRA_DIST = \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
- system-tools-backends.pc.in \
- guess_system.sh \
- type1inst \
+ system-tools-backends-2.0.pc.in \
README \
AUTHORS \
NEWS
-CLEANFILES = $(backends) $(perl_libs)
+CLEANFILES = $(scripts)
-DISTCLEANFILES = \
+DISTCLEANFILES = \
intltool-extract \
intltool-merge \
intltool-update
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = system-tools-backends.pc
+pkgconfig_DATA = system-tools-backends-2.0.pc
+
+# Dbus service file
+servicedir = $(DBUS_SERVICES_DIR)
+service_DATA = org.freedesktop.SystemToolsBackends.service
+