summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2011-09-15 08:08:53 +0530
committerArun Raghavan <arun.raghavan@collabora.co.uk>2011-10-17 13:55:20 +0530
commit91478c13cd420bd9e3eed76513ecec0e2bf65f07 (patch)
tree6a2f946a3252a8096f80a28eb2f6eafb3c88a25d /configure.ac
parent35f5c9ced443ea6a231be48956bbc0bdbbd8020e (diff)
Initial commit of build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 48 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..71f665b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,48 @@
+# Revision changelog (version - date, svn rev. from upstream that was merged)
+# 0.1 - 15 Sep 2011, r597
+AC_INIT([webrtc-audio-processing], [0.1])
+AM_INIT_AUTOMAKE([tar-ustar])
+
+AC_SUBST(LIBWEBRTC_AUDIO_PROCESSING_VERSION_INFO, [0:0:0])
+
+AM_SILENT_RULES([yes])
+
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_LIBTOOL
+AC_PROG_INSTALL
+
+AC_LANG_C
+AC_LANG_CPLUSPLUS
+
+AC_ARG_WITH([ns-mode],
+ AS_HELP_STRING([--with-ns-mode=float|fixed], [Noise suppresion mode to use. Default is float]))
+
+AS_CASE(["x${with_ns_mode}"],
+ ["fixed"], [NS_FIXED=1],
+ ["float"], [NS_FIXED=0],
+ [NS_FIXED=0])
+AM_CONDITIONAL(NS_FIXED, [test "x${NS_FIXED}" = "x1"])
+
+COMMON_CFLAGS="-DNDEBUG -I\$(srcdir)/main/interface -I\$(top_srcdir)/src -I\$(top_srcdir)/src/modules/interface"
+COMMON_CXXFLAGS="-DNDEBUG -I\$(srcdir)/main/interface -I\$(top_srcdir)/src -I\$(top_srcdir)/src/modules/interface"
+AC_SUBST([COMMON_CFLAGS])
+AC_SUBST([COMMON_CXXFLAGS])
+
+AC_CONFIG_FILES([
+Makefile
+src/Makefile
+src/common_audio/Makefile
+src/common_audio/signal_processing_library/Makefile
+src/common_audio/vad/Makefile
+src/system_wrappers/Makefile
+src/modules/Makefile
+src/modules/audio_processing/Makefile
+src/modules/audio_processing/utility/Makefile
+src/modules/audio_processing/ns/Makefile
+src/modules/audio_processing/aec/Makefile
+src/modules/audio_processing/aecm/Makefile
+src/modules/audio_processing/agc/Makefile
+])
+
+AC_OUTPUT